locked HO BLI/QSI Steam Locomotives


michael DUNNINGTON
 

Has anyone in the group had any experience with "older" Broadway Limited steam locomotives?  I acquired one (decorated as a SOU 2-8-2 #6326) recently at an estate sale.  I operate only DC, but they're supposed to run on DC.  Anyway, when I powered it up, it made start-up sounds, but would not run.  Having contacted BLI, I was told that it's a discontinued, QSI-sound-equipped model, older than fifteen years.  I managed to do a reset on the locomotive, but it still won't run.  I'm suspecting that there's a motor/gearing problem, since it makes a vague rumbling sound when it should be running.
In any case, it didn't come with any parts/service drawings, and they're no longer available from Broadway Limited.  I'm hoping that someone in this group might have experience with one like mine, or similar in age.
Thanks for any help you might offer.
Michael Dunnington
St. Louis, MO, area


rwbrv4
 

Contact me off list at dccinstallssales@... 
Rick




On Sunday, January 24, 2021 cvlwrnut <main@SouthernRailway.groups.io> wrote:

Has anyone in the group had any experience with "older" Broadway Limited steam locomotives?  I acquired one (decorated as a SOU 2-8-2 #6326) recently at an estate sale.  I operate only DC, but they're supposed to run on DC.  Anyway, when I powered it up, it made start-up sounds, but would not run.  Having contacted BLI, I was told that it's a discontinued, QSI-sound-equipped model, older than fifteen years.  I managed to do a reset on the locomotive, but it still won't run.  I'm suspecting that there's a motor/gearing problem, since it makes a vague rumbling sound when it should be running.
In any case, it didn't come with any parts/service drawings, and they're no longer available from Broadway Limited.  I'm hoping that someone in this group might have experience with one like mine, or similar in age.
Thanks for any help you might offer.
Michael Dunnington
St. Louis, MO, area


Eric Schrowang
 

Mike 
Might want to check with the repower regear group on Facebook.

Eric

On Sun, Jan 24, 2021, 16:58 <cvlwrnut@...> wrote:
Has anyone in the group had any experience with "older" Broadway Limited steam locomotives?  I acquired one (decorated as a SOU 2-8-2 #6326) recently at an estate sale.  I operate only DC, but they're supposed to run on DC.  Anyway, when I powered it up, it made start-up sounds, but would not run.  Having contacted BLI, I was told that it's a discontinued, QSI-sound-equipped model, older than fifteen years.  I managed to do a reset on the locomotive, but it still won't run.  I'm suspecting that there's a motor/gearing problem, since it makes a vague rumbling sound when it should be running.
In any case, it didn't come with any parts/service drawings, and they're no longer available from Broadway Limited.  I'm hoping that someone in this group might have experience with one like mine, or similar in age.
Thanks for any help you might offer.
Michael Dunnington
St. Louis, MO, area


rwbrv4
 

If it was in the original box please send me a photo of the box end with all it's information.
Rick


-----Original Message-----
From: cvlwrnut@...
To: main@SouthernRailway.groups.io
Sent: Sun, Jan 24, 2021 4:21 pm
Subject: [SouthernRailway] HO BLI/QSI Steam Locomotives

Has anyone in the group had any experience with "older" Broadway Limited steam locomotives?  I acquired one (decorated as a SOU 2-8-2 #6326) recently at an estate sale.  I operate only DC, but they're supposed to run on DC.  Anyway, when I powered it up, it made start-up sounds, but would not run.  Having contacted BLI, I was told that it's a discontinued, QSI-sound-equipped model, older than fifteen years.  I managed to do a reset on the locomotive, but it still won't run.  I'm suspecting that there's a motor/gearing problem, since it makes a vague rumbling sound when it should be running.
In any case, it didn't come with any parts/service drawings, and they're no longer available from Broadway Limited.  I'm hoping that someone in this group might have experience with one like mine, or similar in age.
Thanks for any help you might offer.
Michael Dunnington
St. Louis, MO, area


michael DUNNINGTON
 

No original box. Sorry. 
Michael 


On Jan 25, 2021, at 6:36 AM, rwbrv4 via groups.io <dccinstallssales@...> wrote:


If it was in the original box please send me a photo of the box end with all it's information.
Rick


-----Original Message-----
From: cvlwrnut@...
To: main@SouthernRailway.groups.io
Sent: Sun, Jan 24, 2021 4:21 pm
Subject: [SouthernRailway] HO BLI/QSI Steam Locomotives

Has anyone in the group had any experience with "older" Broadway Limited steam locomotives?  I acquired one (decorated as a SOU 2-8-2 #6326) recently at an estate sale.  I operate only DC, but they're supposed to run on DC.  Anyway, when I powered it up, it made start-up sounds, but would not run.  Having contacted BLI, I was told that it's a discontinued, QSI-sound-equipped model, older than fifteen years.  I managed to do a reset on the locomotive, but it still won't run.  I'm suspecting that there's a motor/gearing problem, since it makes a vague rumbling sound when it should be running.
In any case, it didn't come with any parts/service drawings, and they're no longer available from Broadway Limited.  I'm hoping that someone in this group might have experience with one like mine, or similar in age.
Thanks for any help you might offer.
Michael Dunnington
St. Louis, MO, area